Geleneksel mimarida oluştuturulmuş Sunucu Sanallaştırma (Server Virtualization) platformunu görmektesiniz. Platform üzerinde HyperV Server bulunmakta ve HyperV Server ‘in barınmış olduğu fiziksel sunucu da paylaştırılmış bir veri depolama havuzuna bağlanmış.
HyperV Server 1 TB fiziksel bellek bulunmakta ve 1.6 TB bir disk alanı da Page File için ayrılmış durumda. HyperVisor işletim sistemi yerel disk üzerinde çalışmakta Page file ise daha hızlı disk birimi olan paylaştırılmış veri depolama birimi üzerinde. Bir adet sanal makine (Virtual machine) bulunmakta ve bu sanal makine 64 GB sanal belleğe sahip. Sanal Disk (Virtual Hard Disk) ve Virtual Machine Config dosyalarıysa ortak veri depolama ünitesinde barınmakta.
Her şey olması gerektiği gibi Doğru bir şekilde yapılmış. Platform’da ikinci bir HyperV Server var ve iki sunucu Host to Host Cluster mimarisinde çalışmakta. Sanal makine (virtual machine) çalıştıran HyperV Server ‘da bir hata oluşmakta. Bu hata, Fiziksel bir hata da olabilir, HyperVisor seviyesinde yazılımsal bir hatada.
Sanal makine (virtual machine) bir Host to Host cluster mimarisinde çalıştığı için küme içinde bulunan diğer HyperV Server otomatik olarak sanal makine (virtual machine) verilerine erişecek.
Sanal makine, aktif HyperV Server üzerinde ilk önce power off olacak daha sonra virtual harddisk ve Virtual machine config (VMRS ve VMCX) verileri diğer fiziksel sunucuya bağlanacak ve küme içinde bulunan diğer HyperV Server üzerinde çalışacak.
Bu bölüme kadar olan her şey istediğimiz gibi çalışmakta. Iş sürekliliği sağlanmış durumda. Bu mimaride dikkat etmenizi istemiş olduğum yapılandırma, HyperV Server için ayrılmış olan Page File disk alanı. Paylaştırılmış veri depolama havuzunda olsa bile bir Failover cluster mimarisinde bulunmuyor. Çünkü buna ihtiyacı yok…
Page File alanı, hatırlarsanız yerel disk alanında da çalışabilemkte fakat biz bu mimaride ortak veri depolama alanı kullandık nedeni basit, performansa ihtiyacımız olduğu için. Ortak depolama alanı yerel depolama alanından daha hızlı olduğu için bu tasarımı yaptık. Bağlanmış olduğu Fiziksel sunucu da bir hata oluştuğu zaman bu Page File verisinon diğer fiziksel sunucuya taşınmasına gerek yoktur. Çünkü Page file içinde sabit veri yoktur.
Page File verisi, Bellek ile sabit depolama alanı arasında kalan geçiş bölgesidir. Zaten Buffer olarak isimlendirilir ve Türkçe terimde de tampon bölge olarak isim verebiliriz.
Fakat, Virtual machine Config alanı bu şekilde değildir. Smart Paging ‘de HyperV Server ortamında kullanılan bir Page File olsa bile Page File ’deki gibi fiziksel sunucuya ayıramayız. Sanal makine (virtual machine) planlı yada plansız bir aktarım yapıldığı zaman bu alana erişmek ister.
Bunun için, Smart Paging File verisini ortak depolama biriminde çalıştırmalıyız ve HyperV ortamlarında bu ortak alan da Cluster Shared Volume ‘dur.
Bu tasarımda konuşulması gerekli olan başka konularda var. CSV izolasyonu ve kullanıldıysa eğer Dynamic Memory ayarları.
iş sürekliliği kadar performansa etki eden iki farklı yapılandırmadır ve bu çalışmaları da sizlere paylaşmıştık.























